AccessTokenResult.baseUrl is

Hi all,

i noticed that on a self hosted grist installation the plugin api for getAccessToken (grist-plugin-api - Grist Help Center)

const tokenInfo = await grist.docApi.getAccessToken({readOnly: true});

returns a url like this:

So the host is: this does not work.
Is this a setting in my grist installation? Or is this a bug?

Ouch, thanks for flagging that @enthus1ast. I think that ultimately the domain in that URL may come from:

Do you have an APP_HOME_URL environment variable set? If not, can you try setting APP_HOME_URL to e.g. http(s)://, and see if that helps?

1 Like

Yes that fixed it! Thank you!

I’ve added this to my local docker command line:


1 Like