Can't delete table widget

I tried to delete a table widget because I was getting the following error and could not understand what was causing it:

15:28:37 Cannot read properties of undefined (reading 'forEach')

When I tried to delete the table widget, I got this:

15:28:55 [Sandbox] KeyError "'get_record' found no matching record"

The raw data for that table is still there. The table happens to be empty. Not sure what happened.

I exited the document, came back in and the page was gone. I rebuilt it from scratch and everything works fine.

Hi @Martin_E.

You can try force reloading your document and see if that lets you delete the table. You can do so by going to Document Settings (via the “Settings” button in the left panel) and clicking the skull icon in the section that starts with “Engine”. (Your document will visibly reload on click.)

If that doesn’t help, you can share your document with as OWNER so that we can take a closer look. If you remember any specific changes leading up to that error, it would help us troubleshoot the root cause. Thanks.


Thanks. I was able to delete the page after loading a different document and coming back in. After that I recreated the page. All is well. Thanks.

1 Like

Martin, was your document on the public Grist servers?

I had a similar error, exactly YESTERDAY, just like you, that I had not experienced before with Grist. So I am tending to think Grist had some servers problem yesterday or some other problem.

I wonder if more people had such problems yesterday