Choice Lists not working

I’m having a problem with Choice Lists. When I click the “X” icon to remove a previously selected list item from a cell, nothing happens. The item remains in the cell. Likewise, if I click the “X” icon for a Choice List item in the Column Configuration, to remove that item as a list option, nothing happens.

I’m able to remove items from both locations using the backspace key, but it doesn’t work when using the mouse function. Also, it seems there’s no way to rename a choice.

Re: ‘x’ not working in the cell and the ChoiceList editor in the column configuration, that’s strange. Is this only true for ChoiceLists or also for Choices? How about Reference Lists?

Do you have any browser extensions that could be interfering?

Re: editing a choice, there is currently no way to do it, but it is something we’d like to implement. The feature was requested here: Feature Request - Editable Choices

Both X buttons work for me. When editing a cell, make sure you don’t press Esc after deleting a choice because that will discard your edits. When editing the column configuration, make sure you click Save. Clicking outside the choices list in many places will cancel your changes.

Also, removing a choice from the column configuration won’t remove it from the cells. It’ll just make that choice invalid and outlined in red.

1 Like

Here’s a video that demonstrates the issue. This is a fresh Chrome installation with no extensions enabled.

Screen Recording 2021-09-15 at PM

1 Like

Hi Brad. Which operating system are you using? Trying to see if I can reproduce it on a similar system.


I’m using Windows 10

Any custom settings for your Windows cursor? The one in the video looks a little different than the stock Windows cursor, but that might just be the recording software.

Also while you have Grist open, and after you’ve tried to delete a choice with your mouse, can you try this keyboard shortcut to open the error console in Chrome and see if anything red sticks out to you? Control+Shift+J

You can use the same shortcut to close the console.

Thank you.

I’m not using any special settings for the cursor and there are no errors in the console.

We still unfortunately haven’t been able to reproduce this on Windows, although we did make some improvements to click handling on the delete icon which will be available in the next release of Grist. (The change is to disable dragging choices when clicking from the delete icon).

It looks like from your video that it seems to be switching to drag mode when you try to delete, so this might help, but we’ll have to circle back once it’s available and see if the issue still occurs.

I don’t think it’s browser specific, but if you have Edge or Firefox available on your machine, it could be worth checking if you have the same issue on either of those browsers just in case. One other setting I know of in Windows that might cause this is ClickLock being enabled (it’s under additional mouse options in the mouse & touchpad page of the Settings app). I don’t believe this is enabled by default though, so it’s unlikely to be the cause.

1 Like

Hey @bkonia, whenever you have a chance, can you try deleting a choice again and see if it works now? Thanks.


Yes, it works now, in both locations!