Form "Publish" button not showing


I’ve created some forms for work on a work site but the “Publish” button isn’t showing.
Under Manage users I have the “Owner” Role.

If I make a copy of the document to my Personal Space, the button shows and I can Publish the forms.

What am I doing wrong?

Hi @Operations.

There’s a known issue where forms can’t be published if you don’t have owners access to a site. We’ll be addressing this in the next release so that document-level access is respected. Sorry about the trouble.

If you need to publish those forms before then, the easiest way would be to get a site owner to grant you owner access to the site, or publish the form for you.

If that’s not possible, you can also work around it by forcing the button to appear with your browser’s developer tools. If you right click in the vicinity of the other form buttons in the footer, and then click “Inspect”, a panel will open up showing you all the nearby elements on the page. If you then do Cmd/Ctrl-F, and then search for “forms-publish”, it should take you to a (hidden) button element. You can then click it, and then in the “Styles” panel near the top, untick “display: none;”. The same workaround works for showing the button to copy the form link. Note that you’ll still need owners access in the document if doing this; we still enforce you have the appropriate access level in the backend before going through with publishing or unpublishing your form.


1 Like