Grist "Still working..."

I just updated my grist app with about 6 hours of data. I went to another page and now it won’t load. It’s been over 4 minutes. I have tried all pages and nothing loads. I tried to load an older version of the app and it also won’t load. I tried to load from a different PC and no luck. I need access to my data. Any suggestions?

it finally loaded after 31 minutes. I hope this is a rare exception

I just tried again and have the same problem. Is there a general Grist problem, or is it just my app?

Hi @Mike_Moeller, sorry for the slowness. What flavor of Grist are you using? You mention an older version of the app, and using different PCs, is this grist-electron?

hey Paul. I’m using the latest version of grist, I meant I was using an older version of my data that had never had slowdown problems in the past


just mention we encounter the same issue with Grist electron but not so long lag (couple of minutes to validate entered data).
This is quite rare and usualy disappears.
Synchronous events noted : Business on the server (yet I do not know exactly which ones, because this is done by a third party) and sometimes big formula modification (though I did few days ago without any pbs).

About 12 hours ago, I started playing with Action Buttons custom widgets and now when I try to do anything, I get the dreaded “Still Working” message. I let it set for 5 hours and nothing happened. When I refresh the page the “Still Working” message goes away but so do the entry I was trying to make. I can’t even delete the Action Button to see if that is what is causing my problem. I am new to Grist (about 4 weeks) and love the product. I have hundreds of hours invested in my application and really hope this can be fixed.