Help on action button

Hi !

I recently tried using the “Action button” widget, because I believe I’ll be needing it further on in my project.

But I can’t seem to make it work, I keep getting the same error :

cells should contain an object with keys “button”, “description”, “actions”. Missing keys: “button”, “description”, “actions”

I reduced it to the simplest possible form (opposed to generating the result based on more complex code), and still nothing. I don’t understand what I missed.

I isolated a sample here : GPAO - Grist

If anyone can tell me what I missed, I’ll be very, very grateful, because I’ve been going a bit :face_with_head_bandage: :woozy_face: :face_with_spiral_eyes:

Thanks a lot !

Hi Sophie,

I took a look at your document and found something.

If you head to the creator panel for your “test” page and “Action” column… try changing the column type from “Text” to “Any”.

This should fix the issue!


It was that stupid ? :hushed: :open_mouth: :astonished: :scream:

Thanks a lot, I could’ve search for a veeery long time… :face_with_open_eyes_and_hand_over_mouth: :clap:

1 Like