Issues with LinkKey tutorial

I am following tutorial to generate a hyperlink. I am doing following steps

  1. Run Grist as follows:
    docker run --env GRIST_DOMAIN=localhost --env DEBUG=1 -p 8484:8484 -v $PWD/persist:/persist -it gristlabs/grist
  2. Follow tutorial Link Keys Guide - Grist Help Center

I am facing two issues here

  1. When the link is generated, it is generated with hostname which obviously does not work. Here is an example URL →
  • I am even passing GRIST_DOMAIN = localhost but still links are not correct.
  • I tried passing --env GRIST_HOST=localhost but in that case I am not able to load homepage itself.
  • I tried on getgrist and they are correctly generated there. Am I missing some env variable?
  1. The filtering is not working. I made a copy of the solution doc from tutorial. When I click on the link, I see the UUID is in URL but I can see data of all families. A screenshot is attached. What am I doing wrong?


  1. I think the environment variable you need to set is APP_DOC_URL (Maybe APP_HOME_URL, but I’m pretty sure it’s the doc URL, which would make sense).
  2. It looks from the top left like you are visiting the link while logged in, so are gaining the permissions of your user, as well as the link key. Try using the link in an incognito tab? (Or there is also a ‘View As’ in the access rules tab > Users dropdown.)

Thanks for helping, I think there are some bugs

  1. I still cannot make it work. Can someone else give it a try?
    steps are:
    a) run docker run --env APP_DOC_URL=localhost --env DEBUG=1 -p 8484:8484 -v $PWD/persist:/persist -it gristlabs/grist

b) Go to following doc, download. Then go to http://localhost:8484, and import it → Loading... - Grist

c) go to families page and click on a link.

  1. This is working now, so all good. Thank you.

I’ve just had a play, and through trial and error, looks like it is in fact the APP_HOME_URL, and you also need to ensure the scheme (and port if non-standard) is included: so APP_HOME_URL=http://localhost:8484
Hope that works!

I was not adding port, it is working now. Thank you.