Name of Grist documents

Is there a possibility to choose the name of a document? Right now, the name of the document file (the sqlite database) is composed of random characters, which does not make it easy to exchange documents with others (among other things).

I also tried a workaround:
I found the doc id defined in the landing.db, in the docs table and reference to it in acl_rules. I could change the id in both tables to a “human” name, as well as the name of the document file, still, when opening Grist again, I get an error message that the document is not found.

Any input on this?

Thanks in advance!

1 Like

Hi @michelrev, is this with grist-electron? Sorry, file naming on the desktop is a done in a silly way since we were reusing code adapted to running on a server and haven’t had a chance to come up with a clean native solution.

I wouldn’t advise changing document ids in the database, there’s too many ways for that to go wrong. One possible workaround is to have an empty document in a file somewhere, and then when you want new documents just copy that file to have the name you want, and open that file with Grist. Your Documents directory will still end up with a random-character-named file, but now it should be just a link to the properly named file.

For existing files, you could copy them to a properly named file, then open them and work with them there.

Sorry this is so messy!

I’d just like to second michelrev’s request -

When the development team has the time to work on it, it would be really nice to be able to name grist-electron documents and specify where they’re saved just as we can for any other app documents.

One of many side benefits of that would be the ability to use launchers like Quicksilver to open a Grist document quickly and easily. In most apps on the Mac, I can use the Quicksilver launcher to quickly open a specific document in nearly any app just using the keyboard. I can’t (yet) do that with Grist.

Thanks for considering this!

Hi paul-grist!

Thanks a lot for your answer, and no problem at all for having to use a workaround.

I tested this (environment Windows 10 Pro, Grist-electron).

I created an empty document (with just a dummy table with couple of rows).

I copied it under a “normal” name (myname.grist). When I tried to open it in Grist, I get the following error.

When I try to open the original empty document, no problem.

Indeed, there is a link that was created when I tried to open the renamed grist document.

3 Link that was created

Any input?


Hmm looks like there may be a Windows-specific problem, maybe some goof-up with the path. Will try to get someone using Windows to look at it. Thanks for reporting.