Safari on Mac won't let me check checkbox


I just noticed that when I try to checkmark a box the checkbox disappears on the form and it changes to a text value that is then active, so it says false when it hasn’t been checked. If I want to check the checkbox I have to write true in the field. This is not supposed to happen right? I should just be able to check the box, shouldn’t I?

Is this a safari bug?

Kind regards, Henri

When I click a checkbox once, it toggles (on iOS Safari, in particular). When I double-click, it opens the cell for editing, as you describe. The latter isn’t very useful, but it’s a consequence of the spreadsheet-like behavior of letting you type any text into any cell.

If you click once, toggling works reliably for me. Does it not for you?

BTW, the “Switch” version of Toggle columns works the same as a checkbox and looks better (especially on mobile), so I generally use that one.

Hi Dmitry, it works on iOS safari. This happens on Safari on the Mac desktop. When I click once with the mouse on the box, it changes to the text value.

Hmm, I am not seeing that on Mac Safari version 16.4. I am seeing the same behavior as elsewhere – a single click toggles; a double click opens cell for editing. Which version of Safari are you using? Do you have any extensions or add-ons?

I’m running safari 16.6. I just noticed that it happens that when the box is selected and you click then, it switches to the value. So when I accidentally check the checkbox and the box in which the checkbox sits is still active and I click to unselect it immediately, the box will change to text. When I first select a different field and then go back to the box, it will uncheck the box, like I would expect. This behaviour will be weird to a lot of users that are new to Grist, I think