Sharing problem

Hi, I have trouble sharing my documents. I’ve tried sharing “Public access: On”, or just entered an email and set as Editor or Viewer.

In all cases, the person can open the document but the page is blank. Any idea what went wrong?

Are you seeing this for hosted Grist at *, or your own self-hosted installation?

Does the document have any access rules set?

How blank is blank? Do they see some Grist decorations (e.g. the top bar) or is it completely blank?

It’s at *

I haven’t changed the access rules. So I guess they’re still at default setting.

Attached a screenshot of the blank page.

Thanks for the screenshot. Hmm, it looks just like it would for a user who has access to a document, but not to any of the tables within it. By default, an editor or viewer should have access to the tables though. Could you take a screenshot of the access rules just so I can double-check that nothing is off there? Or click the “Allow everyone to view access rules” checkbox and save.

Here are the access rules and invite settings.

grist invite settings Screenshot 2023-01-25 212921

Hi @school, this rule here is the problem:

It says “for any user who isn’t an owner, don’t let them read or write data in any table”.

The lack of read permission is why no table is showing.

If you hit the trash icon on this rule, and save, than viewers and editors should be able to access tables within your document. Or you could click the R square in that rule until it becomes green, then save. This will allow viewers and editors to read tables within your document, but still no-one except owners will be able to update, create, or delete records.

Hope this helps!

1 Like