Some Grist features / API currently not working

I’m not able to access to some functionality either via the web interface or the APIs: for example I’m not able to create a new table or a new column.

I’m wondering if there is some kind of outage or maintenance going on.

As a related question: is there a page with the current status of the server? A place where I can check if the server is working or if there is any kind of issue going on?

Thank you,


The service is operating normally as far as I know. Can you please check if you can work normally with another doc, e.g. this template Lightweight CRM - Grist? (If you make a change, it will turn into a new copy, and you’ll be able to tell if changes to this new document work normally.)

If the issue applies only to your document, it could be some confusion regarding access level, or granular access rules. Things I would check are:

  1. Are you signed in as more than one user (you can tell by opening the account menu, under your user icon). If so, maybe you need to switch which email account you are using?
  2. Are there access rules that prevent you from creating tables or columns?

Another area could be networking. Grist relies on websockets for working with open documents, and on rare occasion some users’ firewalls have interfered with it.

If none of this helps, can you share more details about what’s not working? Any errors in the browser console?

Thank you for the blazingly fast reply.
I’m able to add a table and and a column to the document you’ve shared.
I use only one account, and there are no access rules and I tend to exclude networking or firewall browser issues, I usually work with this setup and experience no problems.

Here are the steps I’v performed.

  1. Exported a document this morning (this is the master doc, when I want to try something new I like to be on the safe side and export / import the doc in a different workspace with a different name)

  2. Imported the doc in a different workspace and changed the name

  3. Try to add a new page with a new table.

The small notice “Still Working” appears on the bottom right corner and stays there forever.

Repeated the same steps trying to add a column instead of a table, with the same outcome.

Any ideas?

Thank you for your kind assistance.


The original document works just fine (can add a new page → new table): the issue is with the document copy. I tried both exporting / importing and duplicating the document from the web console.
I also tried coping a different document (a smaller one, if this is relevant in any way) and for the other document I don’t encounter any issue.

Apparently there is something going one with the (let’s call it) main document that “breaks” the copy or the export/import mechanism.

Hi Fabio! Is this still affecting the new copy of the document? “Still working” can happen if a document has long-running formulas – on a cold open, all formulas re-evaluate, which can make the document unable to process changes until that process completes.

For huge documents with very inefficient formulas, that could take minutes. In theory, a formula could even be in an infinite loop. In practice, it’s hard to imagine either situation if the document is a copy of one that’s working fine.

Hello @dmitry-grist, thank you for the follow up.

I was under the impression that waiting for the document to “stabilize” fixed the “Still Working”, your reply confirms it.

In any case I don’t yet have the full understanding of what’s going on: I don’t think my document can be considered huge (~1800 rows, 1,67 MB, no attachments), so it might be the formulas.

Here are some the tests I’ve performed (alas, I was not very systematic, need to work some more on them):

  • exported the document as a template: no problem here (no data, quicker cold start, makes sense)
  • imported the document in the electron app: mixed results, need to perform more tests, but apparently the “Still Working” did not happen
  • started a local grist server in the docker container and loaded the document: here also mixed results, I spotted some formula errors in the log and I’ve been “distracted” correcting them, so mixed results here, too

By the way: I’ve never tried to run grist locally in the docker container before: I must say it is insightful.

Question 1: errors on formulas can impact performance? Mostly the errors are due to empty / null fields not being managed correctly in the formulas

Question 2: can Access Rules impact performance? My guess is that they are evaluated on access to a certain table, but I’m under the impression that I might be doing something wrong there, too

For now thank you for the support: I’ll wrap up once I have some more evidence.


I am not seeing any obvious culprits. For a document of only 1800 rows, the “Still working” error is surprising. If you find a way to reproduce it reliably, that would help. The other potential explanation is that it has to do with networking – if there was a loss of network connection for some time, it could cause a similar effect.

To answer your questions:

  1. Errors do affect performance a bit, but not in any huge way. It shouldn’t be noticeable for a document of only a couple thousand rows.

  2. Access Rules also affect performance, and they are evaluated on every access. Again, it’s strange to affect performance in a noticeable way for a small document, unless you have many many rules. If you have more than a handful of rules for a table, then there is probably a better way to write the rules.

I would still suspect either formulas or network connectivity (if the problem is no longer reproducible). Some formulas can have non-linear slowness, i.e. where doubling the number of rows makes formulas overall take 4 times the time. Then a couple of thousand rows can take a long time to recompute from scratch.

I performed some more test but I was not able to reproduce the error reliably: I hate to say this, but apparently sometimes the document gets ready (and can be modified without the “still working”) after a little while, sometimes it need a lot of time, but it looks like it eventually it stabilizes

The tests are:

  • export / import or make a copy of the “master” document
  • wait some time (5 to 30 min, or try the day after)
  • open the new document in a browser tab
  • wait some more time (0 to 5 min)
  • try a modification

Sometimes the new doc can be modified after a “short” time, sometimes not, I was not able to find a pattern (time waited, exported or copied) but eventually (like the day after) the document is OK.

What I can say with a certain confidence is that if the document can be modified a first time, then all the subsequent modification works just fine, it seems that once the import/copy is complete, there are no more issues.

Speaking of culprits: I noticed that in the document history there is a modification marked as performed by Grist: in one of the columns we have a reference to an internal link, something like:

and Grist automatically fixes these links to reflect the new URL Id and Doc Name.

At the same time there is a formula that collects these URLs to build a sort of dashboard (I can be more specific if needed), maybe there is some sort of concurrence there.
If you think it’s worth investigating I can try remove the links and/or the formulas o even try to prepare a sample doc with what I am doing (I will need some time for this).

Finally, for the networking issue, I don’t think it’s the case:

  • I have a very stable FTTH line
  • The computer to the router connection is wired (not WiFi)
  • In the tests I performed the copy and the export/import and the open of the new docs almost simultaneously
  • if the “still working” problem appears at the first modification it stays there even if I close the browser tab and reopen the doc
  • in two tabs one document works the other don’t

To wrap up: when I first posted it seemed to me that the error was systematic, but in fact it’s not (apologies for the hurry), if you wait enough the copied document is OK.

This is fine with me, I will continue my work and try to investigate further with less priority.

Thank you again for your patience and support, Grist is indeed a wonderful tool.