Widgets not working with Grist-core release v1.1.5

Hello, since a few days I’ve been using widgets with Grist Core release 1.1.4 and everything worked perfectly. As soon as I upgraded Grist Core to release 1.1.5 widgets stopped working or misbehaved without showing any error messages. I then went back to Grist Core release 1.1.4 and widgets worked perfectly as before. I assume Grist Core 1.1.5 is somewhat buggy.
Has anyone experienced widgets issues with Grist Core 1.1.5. Do I need to setup something specific to make widgets work with Grist 1.1.5?

I noticed a problem start happening recently, but I don’t know for sure if it started when going from v1.1.4 to v1.1.5.

Sometimes a custom widget I was using on a page would just appear as a white section. Expanding/collapsing the widget didn’t fix it. I had to remove the widget from the page and re-add it to get it working again. Looking at the source code on the page, the iframe had style="visibility: hidden;" set on it. I tried looking into the code to see why that was being added, but I wasn’t able to find anything real quick.

But when I changed that in the Dev Tools so it was visibility: visible, the widget appeared like normal and worked (until I refreshed the page and my local CSS change was reset). The iframe had the widget-ready class on it, so it is weird that it was still marked as hidden

Is this the same problem you’re having? With the widget just showing up as an empty white region? If so, is there a visibility: hidden style on one of the elements that you can manually remove to show the widget again? (I know this isn’t a fix, but it would help determine if you and I are having the same problem)

Hey @wunter8.

There was a recent regression that could’ve caused this. There’s a fix for it in the latest image, but not in 1.1.5 (it’ll be included in the next release).

Are your custom widgets loading the plugin API from https://docs.getgrist.com/grist-plugin-api.js or your local Grist instance (e.g. http://localhost:8484/grist-plugin-api.js)?


Right now it’s using docs.getgrist.com. Should I switch to my local Grist instance?

I’d give it a shot and see if it resolves it.

Unfortunately, the version of the plugin API is currently tied to the version of Grist that’s serving it, so what’s at that URL may be slightly out of sync with Grist Core. It normally shouldn’t matter, but we did make some recent changes behind-the-scenes that could cause issues. (Implementing proper versioning is something we’d like to do in the future.)

Sorry about any trouble.


1 Like

yes, I’m having the same problem with 1.1.5. I had to rollback to 1.1.4 to get things working.

I’m loading loading the plugin API from https://docs.getgrist.com/grist-plugin-api.js

Same problem here, and the solution @georgegevoian mentions does fix the problem: my widgets being hosted in a /widgets path of https://MY_GRIST_URL, using <script src="/grist-plugin-api.js"></script> works.

We just released 1.1.6 which should also address the issue, without requiring any changes to the script tag.



I tried 1.1.6 and custom widgets are working as expected. Thx

1 Like