Wrong Time Zone with timestamp

Hey :grinning:,
I am using the API to insert a timestamp : 1657058400
How to make the column using my Time Zone ?
It’s displaying : “05-07-2022” instead of “06-07-2022”

For a column of type DateTime (which is probably what you should use if you are storing timestamps), it has a time zone associated with it, which you can change in the creator panel: Columns & types - Grist Help Center.

The document settings determine the time zone for new columns you create, but if you have columns created before you changed the document’s time zone, you can change the time zone of each of those columns separately.

For a column of type Date, it stores the timestamp of the midnight in UTC. To set values in a Date column using the API, you can pass in strings like 2022-07-12, or a timestamp in seconds of the UTC midnight.